Ubuntu Multilib

After investigating, that only Linux From Scratch, Slackware, Debian, RedHat and Gentoo distro will possible currently to be built as NON-MILTILIB Linux System and Decided to hook Gentoo Linux. Most of the Linux distributions provides some kind of package manager utility. Non-petalinux: Ubuntu 18. Setup a host computer. 2 installation is UG1144. 3 on Ubuntu 12 ## Switch to root user. For uninstalling this package you can easily use the apt command and remove the package from Linux Operating System. It all depends on how you configure the compiler before building it. There are usually multiple repos in a mirror, holding software packages in categories, such as Manjaro's - core, extra, community & multilib repos. 3, and my architecture is x86_64. Hi, I'm currently working on compiling linux multilib version. x86_64 Stack Exchange Network Stack Exchange network consists of 175 Q&A communities including Stack Overflow , the largest, most trusted online community for developers to learn, share their knowledge, and build their careers. STUDENT LICENSE. OK, I Understand. RAM 1GB of RAM is sufficient to start most Halium distributions. xda-developers Chef Central Android [GUIDE] How to Setup Ubuntu 16. Instal l the multilib for g++ In Ubuntu, we just input sudo apt-get install g++-multilib However, the g++ we use is not the latest ver s ion, it is g++ - 4. _____ Linux User 368276 - Machine 277813. A 64-bit installation of Arch Linux with multilib enabled follows a directory structure similar to Debian Squeeze. News and Activity Feeds. 10’ on Google if you want exact details)). 10 Version 2. 04 and then I followed all of the old instruction of the post about Ubuntu installation. แต่เมื่อ Ubuntu มาประกาศว่าจะยกเลิก 32 บิตในเวอร์ชันหน้า (19. 04 LTS xenial Installion: How To Install gcc-5-multilib On Ubuntu 16. Multiarch is a new approach to running programs compiled for one computer architecture on another, particular i386<->amd64 (see 32bit and 64bit for an explanation to these two architectures). How do I find out what compilers are installed on a Debian / Ubuntu / Red hat Enterprise / CentOS Linux operating systems? How do I list all available compiler packages under a Linux operating system using the CLI? GCC is an Acronym for "GNU Compiler Collection". 04 LTS sudo apt-get install gcc-multilib. x86_64!=systemd-libs-219-30. Im running OpenSuse 12. This is a dependency package providing the default GNU C compiler. multilib: respositorio centrado en arquitecturas x86_64, contiene aplicaciones y librerías para usar y compilar aplicaciones de 32-bits en ambientes de 64-bits. The HART (Hardware Access in Real-Time) Toolbox can be used to generate Scicos-blocks for hardware that have a C/C++ interface. Instal l the multilib for g++ In Ubuntu, we just input sudo apt-get install g++-multilib However, the g++ we use is not the latest ver s ion, it is g++ - 4. Ubuntu used to have a hackish way to get a 32-bit runtime on a 64-bit system with the ia32-libs package. In that document I will describe step by step all operations needed to build android ICS for AllWinner cubieboard using XUBUNTU 12. 04 64位下安装Inel-ifort倒腾了两天,windows下没有免费的fortran,ifort编译器,然而intel为ubuntu提供了免费的ifort版本。下面给大家详细列出我的安装过程:1、首先需要下载ifort安装文件,可以…. This will download a file named something like ubuntu-10. Packages in the official repositories are. tcl864安装包 tcl脚本语言安装包,要安装expect脚本,必须先安装tcl。. 04, I also needed to install the version specific one: sudo apt-get install gcc-6-multilib. For example, setting multilib_policy=best on an AMD64 system causes yum to install 64-bit versions of all packages. If you are not the previous uploader, ask the previous uploader before doing the merge. Storage 16GB of storage is required. iso: 2019-08-19 03:15 : 340M :. 04 Bionic Beaver Operating System and Software Versions. The 32-bit compatible libraries are located under /usr/lib32/, and the native 64-bit libraries under /usr/lib/. Re: Installing gcc-4. Due to limitations in the older emul-linux-x86-* multilib solution, it is generally troublesome to toggle eclass based multilib on individual packages. Try 'apt-get -f install' with no packages (or specify a solution). gcc g++ python 2. Login or Register to rate g++-multilib, add a Tag, or designate as an alternative to a Windows app Upload Screenshots Images must be in GIF, JPG, or PNG formats and can be no larger than 2 MB. There are a few options to obtain GCC version in Ubuntu. If Ubuntu is working, you should not have to concern yourself with the details of how it supports different computer architectures; just install the. According to Arch Linux Wiki. Linux & Ubuntu Tips I have started using Linux in 2012. i686 Loaded plugins: product-id, rhnplugin, security, subscription-manager This system is receiving updates from RHN Classic or RHN Satellite. Can I play games on Linux? This is one of the most frequently asked questions by people who are thinking about switching to Linux. Unlike other distros, Gentoo Linux has an advanced package management system called Portage. All Places > Licensing and Installation > Blog > Blog Posts Log in to create and rate content, and to follow, bookmark, and share content with other members. A wrapper around ar that adds a plugin to the command line. It is a collection of compilers. apt-get の実行. This is a dependency package, depending on development packages for the non-default multilib architecture(s). sudo apt-get install openjdk-8-jdk android-tools-adb bc bison build-essential curl flex g++-multilib gcc-multilib. In fact, some people even wonder if they can listen to music or watch movies on Linux. Originally based on Softlanding Linux System, Slackware has been the basis for many other Linux distributions, most notably the first versions of SUSE Linux distributions, and is the oldest distribution that is still maintained. The Filesystem Hierarchy Standard documents the optimal method to achieve a clean separation between 64bit and 32bit software on a single system. The multilib systems use separate library directories for non-native ABIs. It has been identified that this source package produced different results, failed to build or had other issues in a test environment. Generally, we need to keep multiple versions of gcc/g++ to fit our compiling environment. Here are the packages I'm installing beforehand. 2GB or higher is recommended for a better end-user experience. personal web site for my profile and interests. However, that has been deprecated in favour of MultiArch and now we have the following steps to get things like adb and crclient working again:. 04, on older versions it can be installed via tarball. Ubuntu に nkf をインストールする方法を書いていきます。nkf を使うと文字コードを変換したり、改行コードを変換したりできます。 インストールの動作確認は、Vagrant Box の ubuntu/trusty64 で行っています。 手順1. 0), it is allowed to compile and link to 32-bit. The ARM64 project is pleased to announce that all ARM64 profiles are now stable. Multilib is now enabled with --with-multilib-list=rmprofile when building the toolchain from source. Parent Directory - 389-ds-base-1. Hope this will be fixed. Ubuntu eventually gave up that fight and is switching to systemd. Exact hits Package gcc-multilib. 04 and the compiler is not linking correct. Download Venom Linux for free. Here are the packages I'm installing beforehand. OK, I Understand. The 64-bit part of the multilib is a subset of packages which allows to turn a pure 64-bit slackware-64 into a multilib slackware-64. All Places > Licensing and Installation > Blog > Blog Posts Log in to create and rate content, and to follow, bookmark, and share content with other members. EDUCATOR LICENSE. For access to the current development sources of GDC, visit our git repository. Ubuntu 64bit: sudo apt-get install build-essential subversion libncurses5-dev zlib1g-dev gawk gcc. GNU C compiler. For example, with multilib_policy set to all on an AMD64 system, yum would install both the i686 and AMD64 versions of a package, if both were available. News and Activity Feeds. 0 MySQL CentOS 6 CentOS 6. There has been a lot of news and discussion over the weekend on the topic of Steam on Linux and officially supported and recommended distributions. This method is actually cross-compiling: you take a 64-bit toolchain and produce 32-bit binaries. Linaro is a collaborative engineering organization consolidating and optimizing open source software and tools for the Arm architecture. Fout: Multilib version problems found. It is best used together with Xilinx Vivado 2017. ;' means that no multilibs are used. I'm trying to install Quartus II as per the wiki instructions. setting up a linux Ubuntu system for EM image processing. Install Ubuntu, add the repository and re add the multilib stuff, no big deal. apt-get update. [02:44] !cn | vistaboy [02:44] vistaboy: For Ubuntu help in Chinese 您可以访问中文频道: #ubuntu-cn 或者 #ubuntu-tw 或者 #ubuntu-hk [02:44] 喂喂為 [02:45] Does dd_rhelp/dd_rescue copy the entire partition, freespace and all, or does it only copy files?. 1 and it always fails. You need to replace 'plain ol borin' gcc with multilib gcc… First run pacman -Q | grep gcc to see which gcc you have; replace the normal gcc with gcc multilib and update any previous gcc multilib :. 以前の記事で、Windows10のWSLでUbuntuが使えるようにした。そこで、gccやmakeコマンドの開発ツールを使えるようにしたので備忘録を残す。WSLとはいえ基本的にはUbuntuなので、以前、Ubuntu 16. Building GCC 9 on Windows Subsystem for Linux Posted on May 4, 2017 by Paul. 1 in gutsy), you would install {g++-multilib}. You need to replace 'plain ol borin' gcc with multilib gcc… First run pacman -Q | grep gcc to see which gcc you have; replace the normal gcc with gcc multilib and update any previous gcc multilib :. If the Linux distribution supports multilib, then parallel builds of R may be installed in the sub-directories lib (32-bit) and lib64 (64-bit). A package building reproducibly enables third parties to verify that the source matches the distributed binaries. 14 (part of the 4. 4 32 bitの実行ファイルを動かす. Operating System: - Ubuntu 18. If GCC is configured with some multilibs that use glibc and some that do not, this option applies only to the multilibs that use glibc. Why this matters. This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter. Tested on the TI LAUNCHXL2-TMS57012 demo board from an Ubuntu 14. Thanks for the help. This release marks the launch of the new interface for data settings and code_aster computations launching, AsterStudy. x for Linux >. Ubuntu says it's stranding a mere 1% of its current user base on 32-bit version Ubuntu 18. apt-get install gcc-multilib this should also install g++, but in test this with:. You have searched for packages that names contain gcc-multilib in all suites, all sections, and all architectures. Switch to multilib with 32-bit compatibility on Slackware64 Slackware64 is pure 64-bit system and does not contain multilib and 32-bit compatibility packages officially. Considering that. Major PPA/Debian repo cleanup just happened. In that document I will describe step by step all operations needed to build android ICS for AllWinner cubieboard using XUBUNTU 12. The package was superseded by multiarch support so you don't need it any more, but some 64bit packages (which are actually 32bit applications) still depend on this package and because of this, they can't be installed in Ubuntu 14. 0 MySQL CentOS 6 CentOS 6. Gentoo Linux is a versatile and fast, completely free Linux distribution geared towards developers and network professionals. Linux distribution packages. 04 ships with LLVM 6. 4 and Ubuntu 14. Option 1 Issue command “gcc –version” Example :. This is the gnu c compiler, a fairly portable optimizing compiler for c. Live environments and stage archives can be downloaded using the links below. 10 64bit The article contains the necessary instructions about How to Install the Oracle 12c R2 Database on Ubuntu 18. These repos will be duplicated with package content to suit both 32bit & 64bit installations, as well as for any & all the variety of releases that a distro may support. Switch to multilib with 32-bit compatibility on Slackware64 Slackware64 is pure 64-bit system and does not contain multilib and 32-bit compatibility packages officially. Not strictly speaking part of the multiarch spec, but it explains why it works, and clarifies discussion on future developments. The change will show up in the Ubuntu Desktop Next images starting in the 15. in building GDB, you may encounter errors due to missing the ncurses and textinfo libraries. 1-1ubuntu1_amd64. sudo apt-get install gcc-multilib For some reason, on Ubuntu 17. Linux & Ubuntu Tips I have started using Linux in 2012. 1 libstdc++6-4. nam doesnt have. org, kindly donated by NetNix! Yes, the timing is a bit inconvenient as the dust had barely landed from the previous move. The issue is not only with this toolchain - I cannot run ANY 32-bit application which runs OK under Ubuntu on virtual machine. Or just use the Quickstart for Ubuntu 12. The PPA provides both GCC 4. The Pulse Linux client was developed for command-line usage only and has been qualified on CentOS 6. This is only a kang. 10 via the PPA. A multilib 64bit Linux system is capable of running 64bit as well as 32bit software. 1 sudo apt-get update Then run: apt-cache search gcc-7 sample output : gcc-7-base - GCC, the GNU Compiler Collection (base package) gcc-7 - GNU C compiler gcc-7-multilib - GNU C compiler (multilib support) gcc-7-plugin-dev - Files for GNU GCC plugin development. Live environments and stage archives can be downloaded using the links below. 04 Bionic Beaver. gcc g++ python 2. You should consider whether it's time to make an upload. 3-multilib. gcc-multilib-i686-linux-gnu could be converted to Architecture: all and marked Multi-Arch: foreign gcc-multilib-s390x-linux-gnu could be converted to Architecture: all and marked Multi-Arch: foreign gcc-multilib-x86-64-linux-gnu could be converted to Architecture: all and marked Multi-Arch: foreign. Which will install gcc-multilib and any other packages on which it depends. Gentoo Linux is a versatile and fast, completely free Linux distribution geared towards developers and network professionals. 3-multilib on Ubuntu 11. Dec 23, 2016. 10 ได้ทัน จึงเลือกที่จะ. 以下のパッケージをインストールすればよい。 $ sudo apt-get install gcc-multilib g++-multilib. Using Intel Compilers for Linux with Ubuntu. Login or Register to rate gcc-multilib, add a Tag, or designate as an alternative to a Windows app Upload Screenshots Images must be in GIF, JPG, or PNG formats and can be no larger than 2 MB. 04 Serverインストール後、gccを使用することになりgccと入力しEnterキーを押すと端末に以下のメッセージが表示されました。. The standard repos are enabled by default, but if you want to activate Multilib repositories you must uncomment [multilib] directives from /etc/pacman. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. CLFS takes advantage of the target system's capability, by utilizing a multilib capable build system. 2-dev xterm python-crypto cpio python python3 \ python3-pip python3-pexpect xz-utils debianutils iputils-ping libssl-dev. 11 or try to force the 32bits package to 2. GNU C compiler (multilib files) This is the GNU C compiler, a fairly portable optimizing compiler for C. The PPA provides both GCC 4. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. A 64-bit installation of Arch Linux with multilib enabled follows a directory structure similar to Debian Squeeze. 1 Overview This manual is applicable to the development of RK3399 excavator with opensource kernel (pathed. gcc-7-test-results - Test results. This blog can teach you how to switch your system gcc/g++ version in ubuntu system. How to install gcc-5-multilib-arm-linux-gnueabihf on Ubuntu 16. GitHub Gist: instantly share code, notes, and snippets. Build as offload target compiler. Going to No-Multilib Standard gentoo installation is Net Install. The package was superseded by multiarch support so you don't need it any more, but some 64bit packages (which are actually 32bit applications) still depend on this package and because of this, they can't be installed in Ubuntu 14. Hi, I'm currently working on compiling linux multilib version. 04 Bionic Beaver; Requirements Privileged access to your Ubuntu System as root or via sudo command is required. Available as of Ubuntu 14. 10 support, this decision makes more sense. It may also make sense to install multilib-devel to provide some important you will need to install the 32-bit version of your graphics driver (the package in alternatively, you can edit the following desktop file, and manually add the parameter: attempt to emulate the Ubuntu 12. This blog is a collection of tips intended mainly for my own use. My expectation is that Flathub will become the de-facto app. Portal Berbagi Informasi Yang Berfaedah. In this brief tutorial, let us see how to check if a package is installed or not in DEB based systems. pacman uses libalpm (Arch Linux Package Management (ALPM) library) as a back-end to perform all the actions. all — always install every possible architecture for every package. ServerProtect for Linux インストール作業中に、前提パッケージが入らず本気で悩んだのでメモを残す。 yum力が足りないコピペerで本当すいませ yum実行時 Error: Multilib version problems found. 6 on Ubuntu Bionic 18. on architectures with multilib support, the package contains files and dependencies for the non-default multilib architecture(s). For example, apt-get, dpkg, rpm, yum, etc. 8, improved support for dual-booting Solus with Windows (an issue I experienced continuously during my use of Solus and I mostly fixed with the “sudo update-grub command”), Improved Intel. Build as offload target compiler. The same applies to Vega GPUs except you need to use unstable Padoka PPA instead. 04, this is tri-arch with x32 multilibs are available. What ever Linux Live CD is usable to build gentoo system. Due to Ubuntu's Open Source nature and architecture, it is possible and encouraged to enable other devices to run the mobile OS. rpm: 2018-05-09 22:45 : 1. Bumblebee no ubuntu. Prerequisites. For the DDX driver (which provides 2D acceleration in Xorg), install the xf86-video-intel package. 04 64bit なのですが、クロスコンパイル環境などで提供されている32bitアプリが動作させるのに苦労したためメモします。. It is a compatibility layer needed by packages that have not been upgraded to the libusb-1. I am having an issue updating Oracle LInux 6 servers, using Spacewalk or running "yum update" locally. Applications like ffmpeg and the x265 CLI which use our bit-depth introspection API (x265_api_get) instead of the globally exported C interface can select between 8 and 10bit libx265 libraries at runtime. But after that, when I run make the compilation stops at around 44% : Here are the last lines from the make command stdout :. 01) process through a CD/USB bootable image on UEFI based machines. After trying to fix this issue for 2 days I finally gave up, installed Virtual Box and compile my project under Ubuntu on Virtual Machine. pacman is a command-line utility to install, build, remove and manage Arch Linux packages. CentOS comes with multilib support, since your 64 bit processor can run 32 bit binaries, yum sees no issues with having 32 bit and 64 bit packages installed at the same time. On other distributions, package names and names of cross compilation tools may differ. Error: Multilib version problems found. It is intended for new installations only; an existing Arch Linux system can always be updated with pacman -Syu. all — always install every possible architecture for every package. 2-dev xterm python-crypto cpio python python3 \ python3-pip python3-pexpect xz-utils debianutils iputils-ping libssl-dev. It is best used together with Xilinx Vivado 2017. apt install autoconf autoconf-archive libtool make gcc g++ gcc-multilib gcc-6-plugin-dev libcloog-ppl1 libboost-all-dev libmpc-dev libmpfr-dev libxml2-dev liblzma-dev libmpfi-dev zlib1g-dev libicu-dev bison doxygen flex graphviz iverilog verilator pkg-config libsuitesparse-dev libglpk-dev CentOS 6/Scientific Linux distributions. In this post, I'll describe how to manually get a version of MinGW-w64 that (should) supports multilib (i. One of its greatest strengths is the amount of software that’s available for it, and cross compilers are no exception. 0 and thereby inherits the system requirements from Qt. x86_64 Can anyone please advise how to get around this? I really really need this piece of software to work and I've worked very hard to get all other issues with this software fixed - i think this is my last. Storage 16GB of storage is required. ) For Vulkan support (Ivy Bridge and newer), install the vulkan-intel package. This article contains instructions on how to create a true multilib Slackware64. Venom Linux is source based linux distribution based on Linux From Scratch (LFS) with multilib support and heavily modified for daily use. [email protected]:~$ sudo apt-get install g++-multilib lib32z1-dev lib32ncurses5-dev lib32readline5-dev gcc-4. For that, we've put together the most used libraries and stuck them into the so-called emul-linux-x86 packages, which are located in the app-emulation category. The HART (Hardware Access in Real-Time) Toolbox can be used to generate Scicos-blocks for hardware that have a C/C++ interface. 3-multilib g++-4. Error: Multilib version problems found. 10 or greater. apt-get install gcc-multilib this should also install g++, but in test this with:. openSUSE Tumbleweed is a rolling-release. Arch Repo Name Version Description Last Updated Flag Date; x86_64: Multilib: lib32-fakeroot: 1. Same info are valid for all UBUNTU 12. You need a host computer to compile the Linux and uBoot source code. Perhaps this is the thing that makes Canonical re-evaluate their decision to drop 32-bit multilib support. Since Ubuntu 18. By default, Ubuntu 16. [email protected]:~$ sudo apt-get install g++-multilib lib32z1-dev lib32ncurses5-dev lib32readline5-dev gcc-4. Enable it. x86_64!=systemd-libs-219-30. Android Multilib Build Cheat Sheet AOSP build configurations 32-bit and 64-bit only builds Multilib builds How to do a Multilib build? Multilib platform configuration Building Multilib modules Multilib examples from android-5. 0), Debian and Ubuntu have multiarch support: you can mix x86_32 (i386) and x86_64 (amd64) packages on the same system in a straightforward way. Then purge XBMC PPA: sudo ppa-purge. linux multilib for raspberry pi Tue Apr 09, 2013 7:59 pm anyone think of building a multimib system with both abis (i. This makes arm-linux-gnueabi and armeb-linux-gnueabi toolchains use the "soft" FP ABI instead of "softfp". In this post, I'll describe how to manually get a version of MinGW-w64 that (should) supports multilib (i. x for Linux >. You will be sent email requesting confirmation, to prevent others from gratuitously subscribing you. This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter. Ubuntu for devices runs on a variety of mobile devices, such as the Nexus 4 and Nexus 7 2013 (reference hardware) or the bq Aquaris (commercial phone). Not strictly speaking part of the multiarch spec, but it explains why it works, and clarifies discussion on future developments. Manjaro Linux is an open source Linux distribution based on Arch Linux. REAPER has no native bridge to run Windows VSTs on Linux, but there. Source based linux distribution. Devices - porting to a new device. This tutorial presents a step by step basic Arch Linux installation (current version 2017. 10 will cause problems on an Ubuntu 14. 0 the gcc-arm-embedded toolchain is recommended. I have tested that this can be installed correctly (side-by-side) using yum as long as protected_multilib=false - I also force installonlypkgs to the same name and installonly_limit=0. You need a host computer to compile the Linux and uBoot source code. It’s light, fast and stable Linux distro and available in the most desktop environment including, XFCE, KDE, MATE, and Gnome. Several other `MULTILIB' variables may also be defined there. Bumblebee no ubuntu. 1 Updated for PetaLinux Tools 2. Each multilib variant is mapped to a multiarch configuration. GitHub is home to over 40 million developers working together to host and review code, manage projects, and build software together. Can I play games on Linux? This is one of the most frequently asked questions by people who are thinking about switching to Linux. You will be sent email requesting confirmation, to prevent others from gratuitously subscribing you. What ever Linux Live CD is usable to build gentoo system. Most of the Linux distributions provides some kind of package manager utility. Cross-Compiling from x86_64 to ARM¶. Add the installation sources for the Paparazzi software packages. ) sudo apt update sudo apt dist-upgrade And press 'y' to continue. Multilib is now enabled with --with-multilib-list=rmprofile when building the toolchain from source. Install Dr. gcc-7-test-results - Test results. In this article, I will show you how to compile from sources GCC 9. you get the idea). nam doesnt have. Operating System: - Ubuntu 18. It says that I need the package lib32-libpng12 but when I try to install it from the AUR I get the conflict:. 我看ubuntu的gcc源里面还有一个multilib 这个是做分布式计算的吗? 和Hadoop相比如何呢? by donet8 - C/C++ - 2016-02-27 11:05:19 阅读(9263) 回复(3). Comparison of multilib approaches. 04 LTS xenial Installion: How To Install gcc-multilib On Ubuntu 16. Recently Manjaro team released Manjaro LXQt 16. Additionally there are testing repositories which include binary package candidates for other repositories. 04 Bionic Beaver; Requirements Privileged access to your Ubuntu System as root or via sudo command is required. 2011-04-04 2. Well, this is interesting: it looks like Steam for Linux is now available to install as a Flatpak app. 93 introduced Linux-native builds to the popular digital audio workstation, many users are wondering how they can use their favorite Windows-based VST plug-ins in the Linux builds. This is known as multiarch support See warl0ck's answer for more details. x-multilib package, which helps set up your build environment with the most common. 10 is no longer supported, but may be useful for building older releases of AOSP. REAPER has no native bridge to run Windows VSTs on Linux, but there. What ever Linux Live CD is usable to build gentoo system. Building CLFS teaches you about all that makes Linux tick, how things work together and depend on each other. 04 and the compiler is not linking correct. The X Binary Package System (or xbps) is the binary package system used by Void Linux. GNU C compiler (multilib files) This is the GNU C compiler, a fairly portable optimizing compiler for C. The image can be burned to a CD, mounted as an ISO file, or be directly written to a USB stick using a utility like dd. 04 64bit なのですが、クロスコンパイル環境などで提供されている32bitアプリが動作させるのに苦労したためメモします。. Installation (Linux multilib) To build the Linux cross-compiler with support for both 32-bit and 64-bit, run the following commands:.